nacos 1.3.2 初次下载解压运行报错 DB.NUM IS NULL
nacos启动报错,db.num is null,Unable to start embedded Tomcat
mysql新建库:nacos,字符集:utf8 ,排序规则:utf8_general_ci
第一步:
修改application.properties
第二步:
默认的启动里面是配置的集群版的
本机运行的话要改成单机版即可
打开解压后的文件夹
set MODE="standalone"
执行到这里应该没有错
但实际上是有问题的
我没有去改启动文件的配置(实测改不改都会提示这个) 我是直接加了参数启动的
但启动时控制台一直报这个提示
打开启动文件看看什么情况 果然是这里
但实际这个是不同linux分支中shell的版本支持的问题
我当前的是centos
所以将shell脚本第一行#!/bin/sh换成#!/bin/bash
再次带参数启动就OK了 所以 我用的是 standalone 模式,不是集群模式